Bug report #1467

In QML and QGS saved labels will not be reloaded to a layer

Added by Horst Düster almost 12 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11527

Description

1. load a layer (POINT)
2. create labels
3. save QML symbolisation
4. reload QML

--> no label appears

History

#1 Updated by Jürgen Fischer almost 12 years ago

not reproducable here. maybe fixed with 270fe71f (SVN r9748) and/or ?

#2 Updated by Horst Düster almost 12 years ago

Replying to [comment:1 jef]:

not reproducable here. maybe fixed with 270fe71f (SVN r9748) and/or ?

No this issue is not fixed with 270fe71f (SVN r9748) and/or . This issue appers also when I save a project with labels. After reloading the project all labels are gone.

#3 Updated by Horst Düster almost 12 years ago

I made some tests and it looks that the problem appears only with PostGIS layer. When I save and reload a project with labeled shape-files everything works fine.

#4 Updated by Marco Hugentobler almost 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

I think this is fixed in . The problem was that the label class assumed the attribute indices from 0 to number of attributes. But for postgis layers this is not true because the geometry attribute can be in between.
Please test if it works now and reopen the ticket if not.

Marco

#5 Updated by Anonymous over 11 years ago

Milestone Version 1.0.1 deleted

Also available in: Atom PDF