Bug report #14665

GDAL/Processing toolbox graphical modeller fails during Warp algorithm

Added by Janos Meszaros over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Modeller
Affected QGIS version:2.14.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:22629

Description

A small Graphical modeller model was created to merge and warp two raster layers and finally clip this mosaic by a vector layer (containing a polygon). Unfortunately, it failed so I started to delete steps backwards and finally it found out that in Warp step algorithm missing/fails an ESRI Shapefile or its CRS info. Same model was tested on other computers and it also failed with the same datasets.
I used latest QGIS version, installed with OSGeo4W on Win10 and Win8.1, both 64bit.
Log of my model in a textfile, the model and two raster file as input data to reconstruct my problem are attached.

graphical_modeller_log.txt Magnifier (2.25 KB) Janos Meszaros, 2016-04-12 04:47 AM

raster_clipper.model (6.12 KB) Janos Meszaros, 2016-04-12 04:47 AM

srtm01.tif (171 KB) Janos Meszaros, 2016-04-12 04:47 AM

srtm02.tif (152 KB) Janos Meszaros, 2016-04-12 04:47 AM

History

#1 Updated by Alexander Bruy over 4 years ago

  • Tag deleted (gdal, warp, graphical modeller)
  • Status changed from Open to Feedback

I can't reproduce you error: there is nothing about shapefiles in Processing log when I execute your model. When I try to perform reprojection of the merged raster using GDAL commandline tools I get following error

Creating output file that is 0P x 0L.
ERROR 1: Attempt to create 0x0 dataset is illegal,sizes must be larger than zero.

Seems something wrong with your data.

#2 Updated by Janos Meszaros over 4 years ago

Raster layers are OK if I want to merge visualize or edit them somehow. Sad that my error could not be reproducable, did you tested the model file, too? Is it sure that GDAL algorithms are working properly?

#3 Updated by Giovanni Manghi over 4 years ago

see also #14868

there issue is the same (SHP set as output format for an operation that only output rasters).

#4 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

See #14868

problem solved by purging the .qgis2 folder. Likely to be the same issue as here. Please reopen if necessary.

Also available in: Atom PDF