Bug report #14607

import from SQL Server (2012)

Added by James Burn over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Attribute table
Affected QGIS version:2.14.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:22573

Description

When importing certain datasets from SQL Server, sometimes a random field displays as "null" in the attribute table and identify results. I say random as I have yet to discover a pattern (varchar, char, text etc. doesn't seem to matter). However - other functions in QGIS DO recognize the values such as categorizing the symbology or filtering in the "Add MSSQL Table(s)" dialogue. It just seems to not be showing the information in the attribute table or with the identify features tool.

I have tested the same tables against QGIS 2.12 and found that everything worked fine in that version, so this seems to be a new bug related to 2.14 only.

Thank you.

History

#1 Updated by Nyall Dawson over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

This was fixed in 2.14.1 - please upgrade

Also available in: Atom PDF