Bug report #14599

Processing guidelines for help files is outdated

Added by matteo ghetta about 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Documentation and Help
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22567

Description

Here the link of the official webpage

http://docs.qgis.org/2.8/en/docs/documentation_guidelines/README.html#documenting-processing-algorithms

some points are outdated:

  • SAGA help files are not available anymore
  • it is quite difficult for a potential doc writer to understand where the files are located
  • QGIS algs have .yml syntax
  • maybe it is worth to have a standard template for all the providers (at the moment gdal/ogr points to their own docs, SAGA are missing, GRASS and TauDEM have their own..)

History

#1 Updated by Harrissou Santanna over 3 years ago

I was about closing this one but rather simply made a copy at https://github.com/qgis/QGIS-Documentation/issues/1308 (because not really clear/sure whether processing algs documentation should be in the user manual or in the application)

#2 Updated by Alexander Bruy almost 3 years ago

  • Status changed from Open to Closed

Issue moved to the documentation bugtracker

Also available in: Atom PDF