Bug report #14548

CRS of new spatial bookmarks does't match CRS of current project

Added by R. R. over 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:22521

Description

Subject says it all, I suppose it's a bug.

sb_crs.png (45.6 KB) R. R., 2016-03-23 12:11 AM

History

#1 Updated by Maximilian Krambach over 4 years ago

The code at qgsbookmarks.cpp:156 currently uses srsid(), which is the (correct) internal ID used by QGIS, but meaningless to the user. Expected behavior is the display of a EPSG code. Thus, changing srsid() to authid() would be better.

#2 Updated by Maximilian Krambach over 4 years ago

As usual, it's not as simple as changing just the value, several calculations depend on srid (all in the same file). I'd suggest adding an extra column, "authid", which will contain the EPSG code.

#3 Updated by Nyall Dawson over 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #14393

#4 Updated by Jürgen Fischer almost 3 years ago

  • Category set to Unknown

Also available in: Atom PDF