Bug report #14499

GRASS GIS 7 CRS issue

Added by R. R. over 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GRASS
Affected QGIS version:2.14.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:22474

Description

In my case the output layer of a GRASS GIS 7 command always has a generated CRS:

+proj=tmerc +lat_0=0 +lon_0=16.33333333333333 +k=1 +x_0=0 +y_0=-5000000 +ellps=bessel +units=m +no_defs

The CRS of the project and the input layers is MGI / Austria GK East (+proj=tmerc +lat_0=0 +lon_0=16.33333333333333 +k=1 +x_0=0 +y_0=-5000000 +ellps=bessel +towgs84=577.326,90.129,463.919,5.137,1.474,5.297,2.4232 +units=m +no_defs).

WGS 84 (4326) input layers seem to work properly. I haven’t tested other CRS so far.

grass_gis_7_input_crs.png (455 KB) R. R., 2016-03-15 01:10 PM

grass_gis_7_output_crs.png (452 KB) R. R., 2016-03-15 01:10 PM


Related issues

Duplicates QGIS Application - Bug report #11884: Processing generates outputs with no "+towgs84" parameters Closed 2014-12-18

History

#1 Updated by R. R. over 4 years ago

  • Assignee deleted (Victor Olaya)

#2 Updated by Maximilian Krambach over 4 years ago

From the prj files of the shapes:

Created in QGIS:
PROJCS["MGI_Austria_GK_East",GEOGCS["GCS_MGI",DATUM["D_MGI",SPHEROID["Bessel_1841",6377397.155,299.1528128]],PRIMEM["Greenwich",0],UNIT["Degree",...

Output of v.clean via QGIS-toolbox
PROJCS["Transverse_Mercator",GEOGCS["GCS_bessel",DATUM["D_unknown",SPHEROID["Bessel_1841",6377397.155,299.1528128]],PRIMEM["Greenwich",0],UNIT["Degree",...

Imported into a new grass project; exported again
PROJCS["Transverse_Mercator",GEOGCS["GCS_bessel",DATUM["D_Militar_Geographische_Institut",SPHEROID["Bessel_1841",6377397.155,299.1528128]],PRIMEM["Greenwich",0],UNIT["Degree"...

(... is identical)

So the names of the CRS and the Datum differ, but the rest seems okay.

#3 Updated by Paolo Cavallini over 4 years ago

  • OS version set to 10
  • Operating System set to Windows

So apparently +towgs params are stripped. I confirm this for Windows, whereas on Debian it works fine (EPSG:3003 in input results in 3003 in output).

#4 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #11884

#5 Updated by Stefan Blumentrath almost 4 years ago

My guess is that the issue is related to this one:
https://trac.osgeo.org/grass/ticket/3048
(GRASS does not write AUTHORITY parameter (the EPSG code) to GeoTIFFs, thus QGIS makes a guess where it takes the first matching CRS (the ID number of the assigned EPSG code is lower than the original), I presume...).

Also available in: Atom PDF