Bug report #14466

Conditional formatted table cells expressions are evaluated wrong

Added by Arnold Huisman over 4 years ago. Updated almost 2 years ago.

Status:Rejected
Priority:Low
Assignee:Nathan Woodrow
Category:Attribute table
Affected QGIS version:2.14.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:22444

Description

For simple expressions using @value for just the one cell works correctly. When using @value to compare to other cells in the same row, the expression is evaluated wrong, there seems to be bug that causes the expression to be evaluated with old data from a previous row. Ordering the columns makes this very apperent.

In the attachements you can see that Knipsel1 is correct, but Knipsel2 is wrong. There i only changed the ordering of the column, but the expression "@value > "Tot"" is now evaluated wrong (the red value is still less then 'tot').

Sometimes clicking on the cells will change the evalution as well.

Knipsel1.PNG - Right evaluation (8.06 KB) Arnold Huisman, 2016-03-12 04:57 AM

Knipsel2.PNG - Wrong evaluation (8.18 KB) Arnold Huisman, 2016-03-12 04:57 AM

Knipsel3.PNG - Expressions for 'Van' (7.39 KB) Arnold Huisman, 2016-03-12 04:57 AM

Knipsel4.PNG - Expressions for 'Tot' (8.6 KB) Arnold Huisman, 2016-03-12 04:57 AM

conditions.png (53.6 KB) Nathan Woodrow, 2018-10-08 04:47 AM

History

#1 Updated by Anita Graser over 4 years ago

  • Assignee set to Nathan Woodrow
  • Category set to Attribute table

#2 Updated by Giovanni Manghi over 4 years ago

  • Priority changed from Low to Normal

#3 Updated by Giovanni Manghi over 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#4 Updated by Nathan Woodrow almost 2 years ago

I can't seem to replicate this here using the following

#5 Updated by Nathan Woodrow almost 2 years ago

  • Status changed from Open to Feedback
  • Priority changed from Normal to Low

Possible that this has already been fixed in a older version as I can't replicate it in 3.x.

#6 Updated by Nathan Woodrow almost 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Rejected

Can't reproduce here but reopen if it's still happening in lastest nighly builds.

Also available in: Atom PDF