Bug report #14439

border missing when rendering preview in the labelling background's svg picker dialog

Added by Mathieu Pellerin - nIRV over 3 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:22418

Description

See attached screenshot comparison (label-svg-shield-preview-border-issue.png) for an immediate grasp of the problem. When the svg picket widget draws svg preview through the labelling background setting panel, the svg border value doesn't appear to be set properly.

Steps to reproduce
  1. Launch a fresh QGIS session
  2. Add a vector layer
  3. Open the labelling property window, go to the background panel
  4. Enable background, select SVG type, and open the svg picker widget using the "..." button
  5. Notice the border for previewed svgs isn't drawn (or probably more accurately is drawn with a stroke value set to 0)

label-svg-shield-preview-border-issue.png (408 KB) Mathieu Pellerin - nIRV, 2016-03-07 08:30 PM

History

#1 Updated by Nyall Dawson over 3 years ago

  • Status changed from Open to Feedback

I can't reproduce - it looks identical to the svg marker thumbnails to me. Is there something I'm missing?

#2 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

closing for lack of feedback, reopen if necessary.

#3 Updated by Jürgen Fischer almost 2 years ago

  • Category set to Unknown

Also available in: Atom PDF