Bug report #14377

SAGA Zonal Grid Statistics - v2.1.2

Added by Mark Schulz over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Giovanni Manghi
Category:Processing/SAGA
Affected QGIS version:2.8.5 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22359

Description

When I run SAGA Zonal Grid Statistics via QGIS, I get an error that file extents are not the same. However, checking the metadata, the files have exactly the same extent. After some debugging, I found that I must covert all the files to the same type (e.g. float32) with the same NoData values before it will run. The SAGA folks say that zonal statistics should be able to run with all file types as long as the extent is the same.

QGIS 2.8.6
SAGA 2.1.2

History

#1 Updated by Mark Schulz over 4 years ago

I ran the same files through the SAGA GUI instead of QGIS and they run fine through that but will not run via QGIS GUI.

#2 Updated by Giovanni Manghi over 4 years ago

  • Assignee set to Giovanni Manghi
  • Status changed from Open to Feedback
  • Category set to Processing/SAGA

Please try again on QGIS master and report back. thanks.

#3 Updated by Alexander Bruy over 4 years ago

  • Status changed from Feedback to Closed

Closed for the lack of feedback. Please reopen if necessary.

Also available in: Atom PDF