Bug report #14350

Virtual layers problem with accents

Added by Hugo Mercier over 4 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Hugo Mercier
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22335

Description

A query like this : "SELECT * FROM COMMUNE WHERE STATUT = 'Préfecture'" returns nothing ... accents does not seem to be correctly handled

essai.zip (24.5 KB) Alain FERRATON, 2016-10-18 07:11 AM

Associated revisions

Revision 0e704523
Added by Hugo Mercier over 4 years ago

Fix text encoding issues in virtual layers (fixes #14350)

History

#1 Updated by Hugo Mercier over 4 years ago

  • Status changed from Open to Closed

#2 Updated by Alain FERRATON almost 4 years ago

  • Status changed from Closed to Reopened

l'anomalie est réapparue dans QGIS 2.14.4 et QGIS 2.16.

#3 Updated by Alain FERRATON almost 4 years ago

sorry...
the anomaly recurred in QGIS 2.14.4 and 2.16.

#4 Updated by Hugo Mercier almost 4 years ago

I fail to reproduce.
What happens ? Is there any error displayed ?
Could you share a test dataset ?

#5 Updated by Nyall Dawson almost 4 years ago

I'm guessing the reporter is running a Windows build - there seems to be a problem with accents only under Windows, eg the PyQgsVirtualLayerProvider test consistently fails:
http://dash.orfeo-toolbox.org/testDetails.php?test=44799065&build=241189 (incomplete log unfortunately)

#6 Updated by Alain FERRATON over 3 years ago

see test dataset

with SQL : SELECT * FROM essai WHERE "STATUT" = 'Sous-préfecture'

#7 Updated by Hugo Mercier over 3 years ago

That should be fixed now with #164a85acdb42f383b955c82c00f0ac2c0c5ad2ba

PyQgsVirtualLayerProvider is not part anymore of the list of failing tests on CDash https://dash.orfeo-toolbox.org/viewTest.php?onlyfailed&buildid=251261

The fix has been backported to 2.18, 2.14 (and 2.16)

#8 Updated by Giovanni Manghi about 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#9 Updated by Jürgen Fischer over 2 years ago

  • Category set to Unknown

#10 Updated by Hugo Mercier over 2 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF