Bug report #14329

Metasearch Catalog Client: Use behind a proxy with user/password authentification

Added by Joachim Deutmann over 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:Tom Kralidis
Category:MetaSearch Catalogue Client
Affected QGIS version:2.8.2 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:22316

Description

Hallo,

we are using several QGIS 2.8.2 installations behind a proxy server with authentification. I have an installation of geonetwork within my network (access without proxy) and then there are some useful csw services behind the proxy in the WWW. When i try to use the csw (it doesn't matter, if the csw is in my network or in the internet), the following error message returns: "Unbekanter Fehler: <urlopen error [Erno 11004] getaddrinfo failed>". I try all preset services, my own services and other known csw services. The result is the same.

In Qgis, i set the network parameters to:

proxytype: HTTPProxy
host: my local proxy adress
port: 8080
user: my username
password: my password
URL exception: "http://172." (Beginning of my local network)

This work fine with any webservices (WMS, WFS, WPS..) in my intranet and the internet, but not with CSW via the metasearch catalog client.

Do you have any idea?

Thank you for your help!

Best regards
Joachim Deutmann

screen02.PNG (42.4 KB) Joachim Deutmann, 2016-07-14 01:57 AM

screen01.PNG (31.8 KB) Joachim Deutmann, 2016-07-14 01:57 AM

screen03.PNG (66.1 KB) Joachim Deutmann, 2016-07-14 01:57 AM

screen04.PNG (24 KB) Joachim Deutmann, 2016-07-14 01:57 AM

screen05.PNG (24.9 KB) Joachim Deutmann, 2016-07-14 01:57 AM

History

#1 Updated by Tom Kralidis over 3 years ago

Is this still an issue? I am unable to reproduce locally.

#2 Updated by Joachim Deutmann over 3 years ago

Hallo Tom,

yes, it is still an issue. I am not able to connect to any catalogservice, who is behind my proxy. The csw, who is within my network (no need to access over the proxy) is also not available with the csw-plugin.

When i check out the proxy (in the network options of qgis), the plugin works for my internal csw (i tested it a few minutes ago), but i can't work generally without the proxy server, so this is not an solution for me and the other users in my company.

It would be very useful for us, if you can solve the problem with the proxy settings.

Best regards
Joachim

#3 Updated by Luca Morandini over 3 years ago

Not quite sure it is the same issue, but I am not able to connect to a CSW service that is secured with basic authentication.

Other components in QGIS (such as the WFS connector) give the option of adding username and password to the requests, but not MetaSearch, and encoding credentials in the URL causes MetaSearch to treat the URL as malformed.

#4 Updated by Tom Kralidis about 3 years ago

@Luca: this is a different feature/requirement. Can you open a separate MetaSearch ticket please?

#5 Updated by Tom Kralidis about 3 years ago

  • Resolution set to not reproducable

Joachim: I am unable to reproduce. In my test environment, I setup a Squid proxy with authentication and I was able to verify that MetaSearch recognizes the proxy and is able to authenticate (and that it can fail the authentication to prove that it's connecting via proxy).

#6 Updated by Tom Kralidis about 3 years ago

  • Status changed from Open to Closed

#7 Updated by Joachim Deutmann about 3 years ago

Hallo,
i think, the problem must stand in relationship with the proxy. I test something:

first i disable the proxyoptions.
screen02.png

then i close and open qgis and open metasearch and then my local csw. It works.
screen01.png

the i enable the proxyoptions.
screen03.png

then i close and open qgis and open metasearch and then my local csw. It doesn't work.
screen04.png

then i try metasearch and one external csw. It doesn't work.
screen05.png

Also available in: Atom PDF