Bug report #14319

master: coordinates of cursor in statusbar in WGS84 instead of project CRS

Added by Roel Huybrechts almost 5 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22308

Description

The coordinates of the cursor as shown in the statusbar are now always in the WGS84 (EPSG:4326) CRS. These used to be (in QGIS 2.12 and previous) in the project's CRS.

This is important as users use this to navigate the map based on known coordinates.

It only applies to the coordinates of the mouse position: if you switch view to 'extents' using the button on the side the coordinates are in the project's CRS.

Associated revisions

Revision 800b5212
Added by Nyall Dawson almost 5 years ago

Restore default coordinate format to map units (fix #14319)

History

#1 Updated by Nyall Dawson almost 5 years ago

  • Status changed from Open to Closed

#2 Updated by Tudor Bărăscu almost 5 years ago

  • Status changed from Closed to Reopened

I just noticed this issue yesterday.

I just compiled the latest master and it's still present in a project that I'm using.

Can some leftovers be in the xml file or the issue is present everywhere?
I have disabled OTF in the project settings and in Options/settings but I cannot get rid of the wrong WGS84 display.

#3 Updated by Nyall Dawson almost 5 years ago

  • Status changed from Reopened to Closed

Check the coordinate display seeing under project properties

#4 Updated by Tudor Bărăscu almost 5 years ago

Thanks a lot Nyall for the guidance and for your really nice work.
Hadn't noticed those before.

#5 Updated by Jürgen Fischer about 3 years ago

  • Category set to Unknown

Also available in: Atom PDF