Bug report #14315

wkb access out of bounds

Added by dr - over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No

Description

Trying to open "points" WFS layer and get an error "wkb access out of bounds".
http://37.139.6.183/cgi-bin/mapserv?map=/home/dr/wfs/wfs.map

Associated revisions

Revision d2679d6d
Added by Jürgen Fischer over 1 year ago

another fix for gml wkb assembly (fixes #14315)

History

#1 Updated by Jukka Rahkonen over 1 year ago

That server is not correctly configured. If you administrate that server which seems to be Mapserver, add proper extents to the mapfile.

http://37.139.6.183/cgi-bin/mapserv?map=/home/dr/wfs/wfs.map&service=wfs&version=1.0.0&request=getcapabilities

<FeatureType>
<Name>points</Name>
<Title>Точки</Title>
<SRS>EPSG:4326</SRS>
<LatLongBoundingBox minx="-180" miny="-180" maxx="180" maxy="180"/>
</FeatureType>

Service itself works but I can't recommend how to make QGIS more robust against badly configured services.

#2 Updated by Jürgen Fischer over 1 year ago

  • Status changed from Open to Closed

Also available in: Atom PDF