Bug report #14298

Joins are duplicated when duplicating layers

Added by Frank Sokolic over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Sebastian Dietrich
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22289

Description

When a layer is duplicated any joins defined for that layer are also duplicated. This can be replicated as follows:
  1. Create a Join via Layer Properties > Joins
  2. Right-click on the Layer in the Table of Contents and select Duplicate from the context-sensitive menu
  3. Open Layer Properties > Joins for the duplicated layer and the join appears twice

Associated revisions

Revision 7431ec65
Added by Sebastian Dietrich over 4 years ago

create vector joins only once for a duplicated layer (fixes #14298)

Revision 0c0d72bb
Added by Matthias Kuhn over 4 years ago

Merge pull request #2816 from SebDieBln/FixDuplicateJoins

[Bugfix] create vector joins only once for a duplicated layer (fixes #14298)

History

#1 Updated by Sebastian Dietrich over 4 years ago

  • OS version deleted (15.10 64 bit)
  • Operating System deleted (Ubuntu)

Confirmed on current master (1e80a984df3bebc77f52afb3689ec0a71a3e4c1c) on Windows.

#2 Updated by Sebastian Dietrich over 4 years ago

  • % Done changed from 0 to 100
  • Pull Request or Patch supplied changed from No to Yes
  • Assignee set to Sebastian Dietrich
  • Status changed from Open to In Progress
Duplicating vector joins was introduced by

See PR 2816 for a solution.

#3 Updated by Sebastian Dietrich over 4 years ago

  • Target version set to Version 2.14
  • Priority changed from Normal to Severe/Regression

Flagging this as Blocker because it is a regression from 2.12

#4 Updated by Anonymous over 4 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF