Bug report #14274

"Control feature rendering order" checked by default

Added by Harrissou Santanna almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Sebastian Dietrich
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22268

Description

"Control feature rendering order" option is checked by default, even though no condition is set.


Related issues

Duplicated by QGIS Application - Bug report #14293: "Control feature rendering order" option checkbox has an ... Closed 2016-02-14

Associated revisions

Revision 40c65059
Added by Sebastian Dietrich almost 5 years ago

correctly check/uncheck 'Control feature rendering order' (fixes #14274)

Revision a44c8902
Added by Matthias Kuhn almost 5 years ago

Merge pull request #2798 from SebDieBln/Fix_cboRenderingOrder

[Bugfix] correctly check/uncheck 'Control feature rendering order' (fixes #14274)

History

#1 Updated by Sebastian Dietrich almost 5 years ago

  • Status changed from Open to In Progress
  • Assignee set to Sebastian Dietrich

#2 Updated by Sebastian Dietrich almost 5 years ago

This bug also has the effect of unchecking the Control feature rendering order option when opening the properties dialog for a layer that has an order defined.

#3 Updated by Sebastian Dietrich almost 5 years ago

  • Pull Request or Patch supplied changed from No to Yes
  • % Done changed from 0 to 100

See PR 2798 for a solution.

#4 Updated by Harrissou Santanna almost 5 years ago

Thanks Sebastian
Note that I also reported the side effect (in #14293)

#5 Updated by Anonymous almost 5 years ago

  • Status changed from In Progress to Closed

#6 Updated by Sebastian Dietrich almost 5 years ago

I marked #14293 as a duplicate of this an closed it.

#7 Updated by Sebastian Dietrich almost 5 years ago

What do you think of the automatic checkbox in general?

  • Check the box
  • Define an order
  • Uncheck the box
  • Apply and close the dialog
  • Re-open the dialog
  • -> The box is automatically checked again, without user interaction!

Should it be a bug by itself?

#8 Updated by Harrissou Santanna almost 5 years ago

I'm not sure it should check automatically (according to "is there an expression set?"). If I uncheck the box, it means that I don't want to use the expression, it shouldn't get checked next time I open the dialog.
You may test an expression order and then decide to deactivate it (but want to keep the written expression, may be for further purpose). It should behave as any other checkbox (eg, labelling)

#9 Updated by Sebastian Dietrich almost 5 years ago

I see we think into the same direction here and I openend #14323 for this issue.

Also available in: Atom PDF