Bug report #1426

Digitizer allows island creation with no poly selected

Added by barryrowlingson - almost 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11486

Description

If you select 'add island', and don't have a feature selected, you can create an island (which might take some time if you have a detailed island) and then right-click to finish only to get an error because you forgot to select a feature before you started.

Hence loss of work, and hair.

Island creation tool should either be disabled if no features selected, or check at the start instead of the end!

History

#1 Updated by Marco Hugentobler almost 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in 4e35930c (SVN r9706)

#2 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF