Bug report #14207

Cannot save Geopackage file with "-" in its name

Added by Julien K over 4 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:22209

Description

Dear QGis maintainers,

the "save as" command throws an error while trying to save a geopackage file with an hyphen in its name (please see the screenshot attached).

Dis I miss something? Is there a rule for omitting some characters from SQLite filenames?

Kind regards,
Julien

error_save_as_with_hyphen.png (11 KB) Julien K, 2016-02-01 03:37 AM

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Affected QGIS version changed from 2.12.2 to master
  • Category set to Vectors

weird, no issues doing the conversion from the command line with ogr2ogr, I would have expected the same error.

#2 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Johannes Kroeger about 2 years ago

Dupe of #13140

#4 Updated by Nyall Dawson about 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed
  • Description updated (diff)

Also available in: Atom PDF