Bug report #14180

Web -> Save as SVG crashes QGIS

Added by Kurt Ludikovsky over 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:22182

Description

When I try to save a map as an SVG QGIS crashes.

A minidump is available upon request (29 MB).
The map data is just about 20 MB.

This is just with the extension. using svg from thte printing section this works ok.

QGIS: 2.12.3 64 bit
Win 7/64

History

#1 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Feedback

Is this using a plugin? If so, the bug report should be filed with the plugin, not with QGIS itself

#2 Updated by Kurt Ludikovsky over 4 years ago

It's part of the standard distribution.

As the crash occurs immmediatly after calling the function, I can't say if this is core or plugin related.

#3 Updated by Nyall Dawson over 4 years ago

The "web" menu is only populated by plugins though - there's no Web -> Save as SVG option available in core.

#4 Updated by Kurt Ludikovsky over 4 years ago

I just did a simple check and created a simple test file, and the export worked.

So it's possibly really within the integrated plugin (simplesvg from Richard Duivenvoorde).

I'll create an entry there. (Reference https://github.com/rduivenvoorde/simplesvg/issues/12)

#5 Updated by Kurt Ludikovsky over 4 years ago

Nyall Dawson wrote:

The "web" menu is only populated by plugins though - there's no Web -> Save as SVG option available in core.

How is this then installed? I haven't ! It's been a clean install, no add-ons, just what has been downloaded.

But I have previous versions installed (1.8, 2.2). But each version is in a different directory.

Is the registry used for installations? How to handly then different versions.

#6 Updated by Martin Dobias over 4 years ago

Plugins installed by the user are shared by all releases (installations) of QGIS 2.x. Only plugins for QGIS 1.x are independent because they are installed to a different directory.

#7 Updated by Martin Dobias over 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

As this is a plugin related bug, I am closing the report...

#8 Updated by Jürgen Fischer almost 3 years ago

  • Category set to Unknown

Also available in: Atom PDF