Bug report #14118

regression: unchecking one sub-layer of a categorized symbology leads to no features being drawn

Added by Mathieu Pellerin - nIRV almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No

Description

If one sub-layer node of a categorized symbology is unchecked, the whole layer fails to draw features of the other checked sub-layer categories. Not sure when this regression slipped into master, obviously needs addressing ;)

Steps to reproduce
  1. Create a new project, add an existing vector layer with enough features and at least one field to create a categorized symbology
  2. Open the layer property, switch symbology to categorized, enter a field and classify
  3. Click on ok to leave the layer property window and return to the main canvas
  4. Uncheck one sub-layer category in the layer panel
  5. No features will be drawn, even though other sub categories have matching features

QgisCategorizedPartlyShown.png - Screenshot checked sub-layers are drawn (50.5 KB) Sebastian Dietrich, 01/16/2016 03:40 AM

classified_error.zip (729 KB) Mathieu Pellerin - nIRV, 01/17/2016 05:44 PM


Related issues

Related to QGIS Application - Bug report #13972: Categorize symbols uses wrong field after table join Closed 12/10/2015

Associated revisions

Revision 8435fee4
Added by Nyall Dawson almost 2 years ago

Correctly quote field name in categorized filters (fix #14118)

History

#1 Updated by Sebastian Dietrich almost 2 years ago

I can not reproduce using master (1cd4570136344caafebbe911bbe797ddbc87a56a).

Can you post the exact steps to reproduce and attach the files necessary?

Screenshot checked sub-layers are drawn

#2 Updated by Nyall Dawson almost 2 years ago

Also try with

1. Expression compilation switched off
2. A different format dataset

#3 Updated by Mathieu Pellerin - nIRV almost 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

I can't reproduce this regression anymore (while I could yesterday). Closing to remove blocker noise, will re-open if I stumble on it and can attach a test case.

#4 Updated by Mathieu Pellerin - nIRV almost 2 years ago

  • Resolution deleted (not reproducable)
  • File classified_error.zip added
  • Status changed from Closed to Reopened

Ah, found out what triggered the bug, that is a joined field. Attaching a testcase project.

Steps to reproduce
  1. Load the attached classified_error project file
  2. Uncheck one of the sub-layer of the cphum09 layer
  3. Notice all features are gone, even though other sub-layers are checked and should render

#5 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF