Bug report #141

crashes when printing on pdf

Added by scarselli-faunalia-it - over 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Redmine Admin
Category:-
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:10200

Description

When I print on a virtually pdf printer I get this error

Debug: XP������Ͷ��ο0�0�@�}0��}8�8��}8��}�_(��x�����‹���x�����0��}�}8�8��}8��}�_(�~�O���ο:-1076961576 in project file no symbol node in renderitem DOM
Debug: qgslabel.cpp:602 QgsLabel::readXML() got node labelattributes
key: composition_1
QgsComposerMap::recalculate mCalculate = 1
mUserExtent = 1608759.5842439599800855,4829905.6724525298923254 : 1616531.4813295900821686,4836227.1256708903238177
mScale = 0.2
mExtent = 1608433.0327867749147117,4829541.3990617096424103 : 1616858.0327867749147117,4836591.3990617096424103
QgsComposerMap::setOptions
QgsComposerMap::recalculate mCalculate = 1
mUserExtent = 1608759.5842439599800855,4829905.6724525298923254 : 1616531.4813295900821686,4836227.1256708903238177
mScale = 0.2
mExtent = 1608433.0327867749147117,4829541.3990617096424103 : 1616858.0327867749147117,4836591.3990617096424103
QgsComposerMap::setOptions
QgsComposerLabel::QgsComposerLabel()
QgsComposerLabel::readSettings mId = 2
QgsComposerLabel::areaPoints
QgsComposerLabel::areaPoints
QgsComposerLabel::QgsComposerLabel()
QgsComposerLabel::readSettings mId = 3
QgsComposerLabel::areaPoints
QgsComposerLabel::areaPoints
QgsComposerLabel::QgsComposerLabel()
QgsComposerLabel::readSettings mId = 4
QgsComposerLabel::areaPoints
QgsComposerLabel::areaPoints
QgsComposerLabel::QgsComposerLabel()
QgsComposerLabel::readSettings mId = 5
QgsComposerLabel::areaPoints
QgsComposerLabel::areaPoints
draw mPlotStyle = 0 mPreviewMode = 0
use cache
extent = 8425 x 7050
cache = 1000 x 836
transform = Map units/pixel: 8.425 X minimum: 1.60843e+06 Y minimum: 4.82954e+06 Y maximum: 836
scale = 1.685
translate: 35, 40
QgsComposerLabel::render
QgsComposerLabel::render
QgsComposerLabel::render
QgsComposerLabel::render
Resolution = 600
Paper: 420 x 297
Printing ...
draw mPlotStyle = 2 mPreviewMode = 0
render
Segmentation fault

History

#1 Updated by Redmine Admin over 14 years ago

Further testing: printing to cups-pdf produces an empty ~/PDF/_stin_.pdf file

#2 Updated by Redmine Admin about 14 years ago

Further testing confirms the bug.
It seems to be related to the complexity of the image: with only a greyscale grass raster it prints ok, if we overlay a higher resolution layer, it crashes:

use cache
scale = 1.62
translate: 90, 133
draw mPlotStyle = 0
QgsComposerScalebar::render p = 0xafc7897c
mComposition->scale() = 5
QgsComposerScalebar::boundingRect
QgsComposerScalebar::writeSettings
Resolution = 300
Paper: 420 x 297
Printing ...
draw mPlotStyle = 2 mPreviewMode = 0
render
Segmentation fault

#3 Updated by Gavin Macaulay - about 14 years ago

Can you attach a back trace from it crashes?

#4 Updated by Redmine Admin almost 14 years ago

I did some more testing with , and it seems to be working with simple cases, and crashing when I add several grass layers, transparencies etc.:
QgsComposerVectorLegend::render p = 0xafb4707c
mComposition->scale() = 5
font sizes = 71.6139 61.3833 51.1528
layer = 3
layer = 2
mSelected = 0
draw mPlotStyle = 0
QgsComposerScalebar::render p = 0xafb4707c
mComposition->scale() = 5
QgsComposerLabel::render
Resolution = 300
Paper: 420 x 297
Printing ...
draw mPlotStyle = 2 mPreviewMode = 0
render
Segmentation fault

#5 Updated by Gavin Macaulay - almost 14 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

I'm tidying up the 'crash when printing to postscript' tickets - refer to ticket #345 for further details.

#6 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF