Bug report #14081

Processing>QGIS>Vectoroverlay tools>Clip

Added by Lene Fischer almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:2.12.2 Regression?:No
Operating System:Windows 64 bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:22091

Description

In Processing>QGIS>Vectoroverlay tools>Clip function I get no result.
If I use the function in the Vector-menu it work OK. If I use previous version (2.8.3) it works too.

The function Union gives a log message:
_Algorithm Union starting...

global name 'QGis' is not defined See log for more details_

I have added a video and data.

Regards
Lene Fischer

data.zip (64.3 KB) Lene Fischer, 2016-01-10 06:06 AM

History

#1 Updated by Lene Fischer almost 5 years ago

#2 Updated by Lene Fischer almost 5 years ago

Hi again.
Now I have installed 2.12.2 on a virtual computer. And no problems there. So it must be something from my upgrade from 2.12.0. Can´t figure out what. And a bit worried, because I have 2 workshops in this week with people who has done the same.
Regards
Lene

#3 Updated by Victor Olaya almost 5 years ago

Lene

Can you get the log info and paste it here?

Just reproduce the error and then go to the QGIS log, and copy what you will see int he Processing tab

That should help us to find the cause of this problem

Thanks!

#4 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Open to Feedback

Hi,this is what I see:

qgis 2.8.5, works

qgis 2.12.2, error
GEOS geoprocessing error: One or more input features have invalid geometry.

qgis master works

qgis 2.12.2 with updated processing, works

#5 Updated by Victor Olaya almost 5 years ago

Then, it seems that the issue is fixed in master, so we can close this, right?

Might be one of the issues caused by changes in the geometry handling in core, but seems to be solved, i guess

#6 Updated by Alexander Bruy almost 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Works fine in master for me too. Reopen if necessary

#7 Updated by Jordan Brod over 4 years ago

Just had this problem myself, I haven't updated the processing plugin since it killed GRASS last time I did it, but on Line 28 of the Union python file it's missing the import of the QGis class I believe. I added it to that line and the algorithm worked fine after. I'm sure it was fixed in the updated processing but for those not wanting to update they can find that file and add that class.

Also available in: Atom PDF