Bug report #14063

Diagrams: impossible to change the legend until the dialog is validated

Added by Harrissou Santanna over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Diagrams
Affected QGIS version:2.14.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22073

Description

Open a layer properties dialog > diagram tab
Check "Show diagrams for this layer"
In the attributes section, add an attribute to display
It's impossible to change the legend label until you reopen the dialog: you need to click OK and reopen the dialog to be able to customize the legend.

Associated revisions

Revision b8bce97c
Added by Nyall Dawson over 3 years ago

Allow editing newly added diagram attributes (fix #14063)

Revision 8389b7f7
Added by Nyall Dawson over 3 years ago

Allow editing newly added diagram expression attributes (fix #14063)

Revision 602cfa19
Added by Nyall Dawson over 3 years ago

Allow editing newly added diagram expression attributes (fix #14063)

(cherry-picked from 8389b7f703694bf107ffaa85f5b4bda934e2391a)

History

#1 Updated by Nyall Dawson over 3 years ago

  • Status changed from Open to Closed

#2 Updated by Harrissou Santanna over 3 years ago

  • Affected QGIS version changed from 2.12.0 to 2.14.0
  • Assignee set to Nyall Dawson
  • Status changed from Closed to Reopened

The issue is still there if you use an expression on the added field.

#3 Updated by Nyall Dawson over 3 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF