Bug report #14050

Style Manager : trying to add a symbol to a not renamed group fails

Added by Harrissou Santanna over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.12.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22061

Description

Open the Settings menu --> Style Manager
Add a new group. Do not rename it.
All attempts to add symbols to this group fail although tools to do that are available: the new group is not available when using "Apply group" tool, and using "Group symbols" tool does neither add the symbols.
If you close the dialog and reopen it, you then lose the newly created group.

It looks like a created group must be renamed before trying anything with it.

Associated revisions

Revision 62cc59c3
Added by Sebastian Dietrich over 3 years ago

initialize a style group upon creation instead of upon renaming
(fixes #14050)

Revision 115cc483
Added by Nyall Dawson over 3 years ago

Merge pull request #2627 from SebDieBln/FixNewStyleGroup

Initialize a style group upon creation instead of upon renaming (fixes #14050)

History

#1 Updated by Sebastian Dietrich over 3 years ago

See PR 2627 for a solution.

#2 Updated by Nyall Dawson over 3 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF