Bug report #13985

Merge Vector Layer: Attribute values are wrongly assigning if that attribute is not exists in any of input vector layer.

Added by Nag R over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:-
Affected QGIS version:2.12.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21999

Description

Merge Vector Layer: The attributes which are not exists in one of the input vector layer are assigning ‘10’ after merging.
If any attribute are not common in the input layers those must retain as null for the object which is not defined, they should not set with any value while merging the layers.

Merge_Vector_Layers.png (200 KB) Nag R, 2015-12-14 05:06 AM

Inputs_Output.rar (21.7 KB) Nag R, 2015-12-14 05:06 AM

After_Merging.png (92.6 KB) Nag R, 2015-12-14 07:53 PM

History

#1 Updated by Nag R over 4 years ago

#2 Updated by Alexander Bruy over 4 years ago

  • Status changed from Open to Feedback

Can not open attached archive.

This bug should be fixed in the Processing in master

#3 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

closing for lack of feedback and because it seems really fixed in master anyway.

Also available in: Atom PDF