Bug report #13984

custom python init function config is lost in master

Added by Denis Rouzaud almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Alessandro Pasotti
Category:Forms
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:21998

Description

Opening a 2.12 project with current master
If a layer has a custom init function using an external python file
Master loses this config and sets the custom init function as "provide in this dialog" without any code leading to an error.

This causes a python error when opening the form.

I can't provide a minimal example as I don't have a 2.12 installed or built anymore.
I have encountered this over 2 projects file, with the same behavior twice.

Associated revisions

Revision 8c4d8102
Added by Alessandro Pasotti almost 4 years ago

Fixes #13984 custom python init function config is lost in master

Revision ca5707dd
Added by Alessandro Pasotti almost 4 years ago

Merge pull request #2579 from elpaso/bugfix-13984

Fixes #13984 custom python init function config is lost in master

History

#1 Updated by Alessandro Pasotti almost 4 years ago

I asked for a sample project because I tested the import of an old project with init function in the "dotted" form "my_form.my_open" and it was working for me.

BTW I'll test it again an hopefully catch the issue.

The transformation from the old "dotted" format into "provide in this dialog" + "from my_form import my_open" is the expected behavior.

#2 Updated by Alessandro Pasotti almost 4 years ago

  • Status changed from Open to In Progress

#3 Updated by Anonymous almost 4 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF