Bug report #13955

shapefile geometry are never (really) deleted

Added by jerome andal almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:2.12.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:21970

Description

Hi, and sorry for my english level.
Each time i'm trying to delete one geometry, it doesn't works. It seems to work in QGIS but not, the deleted geometry always reappear in others software.
If I don't correct this problem and i continue to work on a shapefile containing 'ghost geometries', i obtain an offset between geometries ans attribute line.
You can check this by showing feature count, when you're deleting one geometry, the feature count decreases. When you're saving change in the layer, the feature count increase again.
It also happen for each spatial operation which make disappear geometry or which need to replace geometries.

This probleme was already existing in the 2.8 version, perhaps in previous one also.

History

#1 Updated by Saber Razmjooei almost 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #11007.

You have already reported the same issue #13953, please check the response and avoid opening new ones.

Thanks,

Also available in: Atom PDF