Bug report #13953

shapefile geometry are never (really) deleted

Added by jerome andal almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:2.12.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:21968

Description

Hi, and sorry for my english level.
Each time i'm trying to delete one geometry, it doesn't works. It seems to work in QGIS but not, the deleted geometry always reappear in others software.
If I don't correct this problem and i continue to work on a shapefile containing 'ghost geometries', i obtain an offset between geometries ans attribute line.
You can check this by showing feature count, when you're deleting one geometry, the feature count decreases. When you're saving change in the layer, the feature count increase again.
It also happen for each spatial operation which make disappear geometry or which need to replace geometries.

This probleme was already existing in the 2.8 version, perhaps in previous one also.


Related issues

Duplicates QGIS Application - Bug report #11007: Deleted/edited features within SHAPEFILE are still recogn... Closed 2014-08-05

History

#1 Updated by Jürgen Fischer almost 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #11007 (and others)

Also available in: Atom PDF