Feature request #13933

Improve help file of "Import vector into POSTGIS" - error when fields have high precision values

Added by Filipe Dias over 3 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:Giovanni Manghi
Category:Documentation and Help
Pull Request or Patch supplied:No Resolution:invalid
Easy fix?:No Copied to github as #:21951

Description

I was trying to import a vector into Postgis using "Import vector into POSTGIS (available connections and new connection)" (OGR Miscellaneous) and got these kinds of errors which, I think, are caused by one of the fields having high precision.

ERROR 1: COPY statement failed.

ERROR:  numeric field overflow
DETAIL:  A field with precision 19, scale 15 must round to an absolute value less than 10^4.
CONTEXT:  COPY teste1, line 58, column perimeter: "15814.399999999999636"

If I uncheck "Keep width and precision of input attributes" it works.

I would suggest add a note on this to the help file

History

#1 Updated by Giovanni Manghi about 2 years ago

  • Easy fix? set to No

#2 Updated by Alexander Bruy over 1 year ago

  • Resolution set to invalid
  • Status changed from Open to Closed
  • Category changed from Processing/GDAL to Documentation and Help
  • Description updated (diff)

Please file ticket in the QGIS documentation bugtracker.

#3 Updated by Harrissou Santanna over 1 year ago

I'm not sure it's worth documentation: the error message says that you are trying to put 15814.xxxx in a field that you design to not take a value higher than 9999.xxxx
It's a normal behavior of data storage, nothing specific to this algorithm imho.

Also available in: Atom PDF