Bug report #13928

Spatialite and Date Field

Added by Randal Hale almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/SpatiaLite
Affected QGIS version:2.12.0 Regression?:No
Operating System:Linux (Ubuntu) Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21946

Description

Building a spatialite database and I can't create a date attribute from the new spatialite layer menu.

History

#1 Updated by Nyall Dawson almost 5 years ago

That's because SpatiaLite databases don't support date or time data types. See https://www.sqlite.org/datatype3.html

#2 Updated by Randal Hale almost 5 years ago

  • Status changed from Open to Closed

Oh man....I stink. I thought there was a datetime data type that ...and I'm reading.....there isn't. I suck. I'm sorry for clogging up the list with bugs that aren't bugs.

#3 Updated by Randal Hale almost 5 years ago

Oh man....I stink. I thought there was a datetime data type that ...and I'm reading.....there isn't. I suck. I'm sorry for clogging up the list with bugs that aren't bugs.

Also available in: Atom PDF