Bug report #13909

Delete ring does not work

Added by Kalle Kronholm almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21931

Description

On a polygon SHP file, I added a ring in QGIS 2.12, using the standard "add ring" tool. Then updated to QGIS 2.12.1. Now trying to delete the ring previously created. I am using the standard "delete ring" tool, and edit mode is toggled. The tool picks up the correct ring, and in edit mode the indicators for the ring vertex points are removed. But the ring is still there. When saving the edits, the ring, including the vertex points are still there. The function worked in QGIS 2.12.

History

#1 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Feedback

Can you share your data file please?

#2 Updated by Kalle Kronholm over 4 years ago

I have upgraded to QGIS 2.13.3 and just tested the delete ring tool. Now it works.

#3 Updated by Nyall Dawson over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF