Bug report #13900

Debian upgrade to 2.8.4

Added by Ian Goddard about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.8.3 Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:21922

Description

Running apt-get upgrade results in the following:
dpkg-divert: error: `diversion of /usr/bin/qgis to /usr/bin/qgis.bin by qgis-provider-grass' clashes with `diversion of /usr/bin/qgis to /usr/bin/qgis.bin by qgis-plugin-grass'
dpkg: error processing /var/cache/apt/archives/qgis-provider-grass_1%3a2.8.4+12wheezy_i386.deb (--unpack):
subprocess new pre-installation script returned error exit status 2

I see similar bugs have been raised recently and marked closed. This bug is live in the new upgrade.

There is a workaround, manually link /usr/bin/qgis to /usr/bin/qgis.bin, but this will result in errors each time apt-get upgrade is run.

Note also I have had to select 2.8.3 as the affected version as 2.8.4 does not appear there despite having been released.


Related issues

Duplicated by QGIS Application - Bug report #14395: Cannot install on ubuntu xenial Closed 2016-03-01

History

#1 Updated by Jürgen Fischer almost 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

see #14395

Also available in: Atom PDF