Bug report #13896

Incorrect encoding for Generic Action

Added by dr - almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Actions
Affected QGIS version:master Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21918

Description

Trying to make simple Generic Action with capturing output (see attachments):

echo "Привет мир" 

But in output window I see gibberish. It looks like encoding issue:

Starting echo "Привет мир"...
Привет мир

Done

20.png (86.1 KB) dr -, 2015-11-29 04:20 AM

46.png (14.3 KB) dr -, 2015-11-29 04:20 AM

Associated revisions

Revision 7fc88c26
Added by Alexander Bruy almost 5 years ago

convert stdout and stderr to correct encoding (fix #13896)

Revision cb7d0fb4
Added by Alexander Bruy over 4 years ago

Merge pull request #2700 from alexbruy/actions-encoding

convert stdout and stderr from actions to correct encoding (fix #13896)

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Category set to Actions

#2 Updated by Alexander Bruy over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF