Bug report #13846

Styling Else rule scale problem

Added by Tudor Bărăscu over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21870

Description

I'm attaching data to recreate the issue.

It's kind of hard to present the issue in words so I'll make just a short summary.
Basically, I have a layer that has rule-based styling.
2 main categories (that exclude each other) with their subcategories + ELSE rule.

With everything checked, I managed to get into a situation where ELSE rules are displayed.
In the second main category I have a subcategory with scale based symbology based on a joined layer.

Deactivating the second category also deactivates the ELSE rule.

The issue is only found in QGIS master, not in the 2.12 release.

styling_bug.zip (32.8 KB) Tudor Bărăscu, 2015-11-17 09:02 PM

History

#1 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Feedback

Looks like you forgot to attach the data & project file?

#2 Updated by Tudor Bărăscu over 4 years ago

Looks like it. I remember clearly that I had put it in the ..upload queue.
Meanwhile, I noticed the issue comes along with bfd2933

Steps to replicate:
- activate/deactivate the second category

As I lost a lot of time trying to recreate it I somewhat lost the clear head state and now I think it's not a bug, but the actual feature that works "differently" then before, but more in a... fixed way.
Many thanks Nyall for your work.

#3 Updated by Tudor Bărăscu over 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF