Bug report #1384

Ubuntu Intrepid GUI load failure

Added by Alex Mandel almost 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Alex Mandel
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11444

Description

On upgrade from Ubuntu 8.04 to 8.10 qgis stops loading, the launcher gets stuck at 'Setting up GUI'
strace and gdb indicate something to do with X.
Along with QGIS lot's of other applications fail:
  • konquerer
  • qt designer
  • eric4
  • texmaker

The problem is actually a package that was upgrading during the dist-upgrade. It has yet to be identified but the list of potential bad packages is attached.

Plan is isolate the package and submit the issue to the appropriate developers. In the mean time we'll need to warn Intrepid users to remove the package.

Note: may not apply to all machines.

testpackages.txt Magnifier - Packages that need testing, to determine if they break qgis. (8.5 KB) Alex Mandel, 2008-11-06 01:15 AM

timpackages.txt Magnifier - These are the packages installed on my system where QGIS will not run (21.6 KB) Tim Sutton, 2008-11-06 10:01 AM

petepackages-upgradejustfine.txt Magnifier (24.3 KB) ersts -, 2008-11-07 10:32 AM

History

#1 Updated by Tim Sutton almost 12 years ago

I've attached my package list for comparison. Although perhaps we need to have package version numbers factored into the mix...

Tim

#2 Updated by ersts - almost 12 years ago

Here is my package list, my upgrade from 8.04 to 8.10 went just fine.

#3 Updated by Tim Sutton almost 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

This seems to be resolvable by doing:

sudo apt-get remove --purge libqt3-headers libqt3-mt libqt3-mt-dev uim-qt3

I believe specifically doing:

sudo apt-get remove --purge uim-qt3

should resolve the issue but needs to be verified.

#4 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF