Bug report #13837

Processing plugin wrong minimal version

Added by Luigi Pirelli almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:High
Assignee:Alexander Bruy
Category:Processing/Core
Affected QGIS version:2.8.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21861

Description

Processing v2.12 is incompatible with QGIS version lesser than 2.12 (sorry for the redundant version number)
metadata.txt says that is compatible with QGIS 2.6, but every QGIS LTR have problems:

"cannot import name show_message_log"

as described in the thread: http://osgeo-org.1560.x6.nabble.com/Problems-with-Plugins-tc5236507.html

this affect affecting all plugins that import processing running on QGIS less that 2.12

History

#1 Updated by Alexander Bruy almost 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

oops, sorry. Plugin metadata now fixed and package updated

#2 Updated by Luigi Pirelli almost 5 years ago

alex, do you mind would be better to update to 2.12.1? there are already more than 1500 downloads and the only way to allow them to update automatically is to change the version

#3 Updated by Alexander Bruy almost 5 years ago

Added 2.12.1 version. Should I remove 2.12.0 then?

#4 Updated by Luigi Pirelli almost 5 years ago

I would remove... I hope this does not generate side effects. I supposed it's safe.

Also available in: Atom PDF