Bug report #13808

Project save time doesn't update after "Save As...'

Added by Spencer Gardner over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:2.10.1 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21833

Description

Steps to reproduce:
  1. Open an existing project file
  2. Select Project -> Save As...
  3. Save the project to a new project file
  4. Select Project -> Save

What happens:
A warning dialog pops up telling me that the loaded project file on disk was changed and asking whether I want to overwrite the changes. The "last modification" date in the dialog corresponds with the save date of the original project.

What should happen:
The new project file created from the "Save As..." is overwritten without warnings, since this is the expected behavior of a "Save" operation.

-------------
As far as I can tell, nothing bad happens if you select "OK" on the dialog (i.e. the original project file is not affected and the new project file is saved), but it is a disconcerting message. I suspect there must be a setting somewhere that tracks the save date of the project when it is first opened and this is not updated to reflect the new save date from the "Save As...", even though the user is technically working on a new project.

History

#1 Updated by Spencer Gardner over 4 years ago

  • Status changed from Open to Closed

Just discovered this bug, which appears to be a duplicate: #13420

Also available in: Atom PDF