Bug report #13769

Help file url is incorrect

Added by Frank Sokolic almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:master Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21795

Description

When using tools in Processing Toolbox > Advanced Interface > QGIS Algorithms the help tab uses an incorrect url.

For example, clicking the help tab for the Clip tool gives this error:

*Not Found*

The requested URL /testing/en/docs/user_manual/processing_algs/qgis/vector_overlay_tools.html/clip.html was not found on this server.

The URL should actually be:

/testing/en/docs/user_manual/processing_algs/qgis/vector_overlay_tools.html#clip

Help_url_error.png (251 KB) Frank Sokolic, 2015-11-06 04:01 AM

inter.png (247 KB) Giovanni Manghi, 2015-11-06 04:13 AM

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Open to Feedback

Cannot replicate here (ubuntu and windows): are you using the latest processing version on master? check if in .qgis2/python/plugins/ you have a "processing" folder, if yes delete it and restart qgis. Thanks.

#2 Updated by Frank Sokolic almost 5 years ago

Yes, I'm using the latest processing version on Master, Ubuntu 15.10 64 bit. I've deleted the processing folder from .qgis, then restarted QGIS but the problem still occurs.

Screen shot attached.

#3 Updated by Giovanni Manghi almost 5 years ago

Frank Sokolic wrote:

Yes, I'm using the latest processing version on Master, Ubuntu 15.10 64 bit. I've deleted the processing folder from .qgis, then restarted QGIS but the problem still occurs.

.qgis2, right?

Screen shot attached.

I'm basically on the same platform, see attached screenshot (works ok for me).

#4 Updated by Frank Sokolic almost 5 years ago

Yes, it is .qgis2

#5 Updated by Frank Sokolic almost 5 years ago

  • Status changed from Feedback to Closed

This problem has been resolved since upgrading to the latest version of processing 2.12.2.

Also available in: Atom PDF