Bug report #1373

Derived area values from identify tool differ from calculated PostGIS area

Added by Horst Düster almost 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Vectors
Affected QGIS version: Regression?:No
Operating System:RedHat Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:11433

Description

When I identify a polygon with the identify tool, the derived area differs from the calculated area with postgis area(the_geom) function. The difference is small but existing:

QGIS: 15.516 km2

PostGIS: 15.525 km2

History

#1 Updated by Steven Mizuno almost 12 years ago

Replying to hdus:

When I identify a polygon with the identify tool, the derived area differs from the calculated area with postgis area(the_geom) function. The difference is small but existing:

QGIS: 15.516 km2

PostGIS: 15.525 km2

If you are using On-the-fly transformation, the difference is because QGIS uses calculation on an ellipsoid rather than plane calculations as PostGIS uses for area().

Without OTF, QGIS uses plane calculations also, but there may still be a very small difference.

This is essentially the same problem as I put in #1219.

#2 Updated by Horst Düster almost 12 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Already reported with #1219

#3 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF