Bug report #13727

Simple Marker Data Defined Anchor Point

Added by Michael Knopp almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.8.1 Regression?:No
Operating System:Mac OSX Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21754

Description

I am trying to use data definition to define a cliff hashmark.

I have created a style for the line with a simple marker and plan to use the vertical anchor point offset to move the marker to the proper side of the line.

I have created a string field with a width of 10 and enter "bottom" or "top" into the field. After creating the line the hashmarks are displayed correctly. However, as soon as I save the shapefile it defaults back to a centered anchor point.

I have tried changing the table and saving. I have quit QGIS and restarted. It is like it doesn't read from the shapefile correctly.

test_data_at_creation.png - Data entered at creation of the line (96.4 KB) Michael Knopp, 2015-11-01 09:28 PM

before_save_display_correctly.png - Just after data entry the anchor point is displayed correctly (80.6 KB) Michael Knopp, 2015-11-01 09:28 PM

after_save_display_incorrect.png - After clicking the "Save Layer Edits" button the anchor point reverts to centered (74.7 KB) Michael Knopp, 2015-11-01 09:28 PM

Hachure_Test.zip - Project and shapefile example (122 KB) Michael Knopp, 2015-11-03 07:09 AM

Installed_Plugins.png - Installed plugins (455 KB) Michael Knopp, 2015-11-03 07:09 AM

History

#1 Updated by Nyall Dawson almost 5 years ago

  • Status changed from Open to Feedback

To confirm, is the data getting saved corrctly into the shapefile (eg browsing the table shows your entered anchor values), or is the data definition getting lost when saving the project?

#2 Updated by Michael Knopp almost 5 years ago

Yes, the data is getting saved to the shapefile. If I open the table the data is shown exactly as entered.

Also, I have tried this on a Windows 7 SP 1 machine also running QGIS 2.8.1 and the behavior is exactly the same.

#3 Updated by Nyall Dawson almost 5 years ago

I can't reproduce. Can you share a small project/sample data which shows this issue?

#4 Updated by Michael Knopp almost 5 years ago

Sure. I just created a very small topo with a cut. Using only these two small shapefiles it is still doing it on my systems.

I also am including a screenshot of my installed plugins. Just in case it is some conflict with one of them.

Thanks.

#5 Updated by Nyall Dawson almost 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Ok, this issue was already fixed in 2.8.2. I've tested your project with 2.8.3 and it works fine.

Also available in: Atom PDF