Bug report #13660

Log messages appear at the top of the screen and don't disappear

Added by Piotr Kania almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:21695

Description

Hi!
Win7sp1 x64, qgis dev x64 rev. 18df003

In Settings/Options/General I set "Timeout for timed messages or dialogs" as 2 sec., but when I try to save edits on postgis layer each time appears at the top of the screen message, that doesn't disappear - I must turn it off manually - and it occurs each time I save edits - and in postgis layers everything is ok - edits are saved etc.
You can see that on that video, but download that and watch locally on computer, as dropbox player reduces resolution:

https://www.dropbox.com/s/qzjzie8pk158296/clip2.mp4?dl=0

In qgis dev x64 rev. 4cdf05f there was no such bug (the same qgis project, postgis layers etc.)

History

#1 Updated by Jürgen Fischer almost 5 years ago

d8303a7 fixes the origin of the messages.

#2 Updated by Nathan Woodrow almost 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Jurgen has fixed the reason for the error. Not all messages are time out based and that setting has no effect on those.

Also available in: Atom PDF