Feature request #13605

Filter mapcomposer-legend to only show layers checked/visible on the map canvas

Added by Filip Mahieu almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No Copied to github as #:21645

Description

In the table of contents you can uncheck certain layers. However, if you make a composer, and you add a legend, all the layers that are in the table of contents are displayed in the legend. It makes no difference if you have checked or unchecked them.
Using the green button 'filter' does not change that behaviour. It still gives you all the layers.

It would be logic and very nice to be able to just have in the legend those layers (in the Composer lenged) that are used in the map canvas.

Someone already made some Python-code to make that possible: http://gis.stackexchange.com/questions/120209/filter-mapcomposer-legend-to-only-show-layers-visible-on-the-map .

Working on Qgis 2.8.3 .

History

#1 Updated by Harrissou Santanna almost 5 years ago

Isn't this a duplicate of #13575?

#2 Updated by Filip Mahieu almost 5 years ago

Yes, indeed, i scrolled along the issues concerning Map Composer, but I must have overlooked it. Thanks.

#3 Updated by Nyall Dawson almost 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF