Bug report #13602

WMS of group layer is drawn in reverse order

Added by Henrik Uggla about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:QGIS Server
Affected QGIS version:2.8.3 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21644

Description

Qgis Server 2.8.1 works fine but both 2.8.2 and 2.8.3 has this issue.

Example:
I, in Qgis Desktop, create a project containing one grouplayer containing three layers like this:

grouplayer1
transparentlayer1
transparentlayer2
opaquelayer1

All looks fine in Qgis Desktop, all layers are visible.
Then I publish it as Qgis Server WMS.
When I do REQUEST=GetMap&LAYER=grouplayer1 the layers are drawn in reverse order like this:

grouplayer1
opaquelayer1
transparentlayer2
transparentlayer1

That means only opaquelayer1 is visible in the WMS response.

If I reverse the layer order in the Qgis project (opaquelayer1 on top, hiding the other two in Qgis Desktop) and publish that then all layers is visible when doing REQUEST=GetMap&LAYER=grouplayer1.

History

#1 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Feedback

Was this solved by 8948721? Can you reproduce in current master/2.12?

#2 Updated by Henrik Uggla about 4 years ago

I've tried the last two nightlies but all I get is "WMS configuration error", so I don't know. I will try again tomorrow.

#3 Updated by Henrik Uggla about 4 years ago

  • Status changed from Feedback to Closed

It is solved in 2.12. Thanks!

Also available in: Atom PDF