Bug report #1359

saving image files: missing extension

Added by Paolo Cavallini almost 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:-
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11419

Description

When saving image files from map composer, the file type extension is not written

History

#1 Updated by Marco Hugentobler almost 12 years ago

You mean the file extension if not written even if entered by the user?
Or do you mean it is not automatically appended?

If it is the first: I cannot reproduce it. Does it only happen in certain cases?

It it is the second: I'm not sure that it should be. In Unix philosophy, the content of the file is independent from its extension.

Marco

#2 Updated by Marco Hugentobler almost 12 years ago

Ok, after looking at other applications: some append extension automatically and others don't. I have the impression that the user-friendly ones do, so we should do it too.

#3 Updated by Anne Ghisla almost 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

QGIS 1.0 preview1 for Windows automatically appends extensions.

#4 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF