Bug report #13583

Snapping options not saved on Windows

Added by Roy Roge almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:GUI
Affected QGIS version:2.8.3 Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21625

Description

In windows, even if you save a project
with configured snapping options,
snapping otions are not configured
when you reopen the project

Create new project and load a shapefile
configure some snapping options
save the project and close.
Reopen the project and check
the snapping options, they are resetted.

snap_settings_project.png (18.1 KB) Saber Razmjooei, 2015-10-14 01:39 PM

History

#1 Updated by Saber Razmjooei almost 5 years ago

In my case, I saved it with the advanced mode. When I re-opened the project the snapping options showing Advanced mode but the dialog is for current layer (see attached).

#2 Updated by Nyall Dawson almost 5 years ago

  • Status changed from Open to Feedback

Saber - that issue was fixed as of ~48 hours ago. Can you retest with current master and report if this is still an issue?

#3 Updated by Saber Razmjooei almost 5 years ago

  • Status changed from Feedback to Closed

Confirmed. It works fine in master. Thanks Nyall.

#4 Updated by Roy Roge almost 5 years ago

  • Status changed from Closed to Reopened

Testing on Master 2.11.0 90
Snapping option for Current layer/All layers
are still not saved;

Advanced settings are saved.

Thanks, Roy.

#5 Updated by Saber Razmjooei almost 5 years ago

  • Status changed from Reopened to Feedback

What code revision are you using? Works fine with all three modes in 5654eec.

#6 Updated by Roy Roge almost 5 years ago

Testing on Master 2.11.0 90 code revision f50e1a7

#7 Updated by Saber Razmjooei almost 5 years ago

It works fine on mine with the same code rev.

#8 Updated by Roy Roge almost 5 years ago

Saber are you using Windows platfom?
if yes what ( windows 7, 8, 10) ?

I tested on Windows 10.

#9 Updated by Saber Razmjooei almost 5 years ago

Windows 7, 64 bit - installed from OSGeo4W
Debian jessie - compiled from source

Could you disable your plugins (renaming .qgis2 folder) and try again?

#10 Updated by Roy Roge almost 5 years ago

Removing the .qgis2 folder works;

Where are those config saved, in a sqlite db?

It also works on 2.8.3 now, very strange!

#11 Updated by Saber Razmjooei almost 5 years ago

  • Status changed from Feedback to Closed

Must have been a user preference or a plugin issue.

#12 Updated by Roy Roge almost 5 years ago

Seems to be a plugin: Semi automatic classification pulgin

Also available in: Atom PDF