Bug report #13573

Composer scale bar : the alignment option doesn't work

Added by Harrissou Santanna almost 5 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21615

Description

Steps:
Add a scale bar in a print composer.
In its properties, Display > Alignment, whatever option you choose nothing happens.

master 15af5a1

History

#1 Updated by Harrissou Santanna almost 5 years ago

If the style chosen for the scale bar is "numeric" then the alignment works.
Since this option is active for the other styles, it should align the text with the border of the segments.

#2 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Nyall Dawson over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • Description updated (diff)

Fixed in 3.0 - the alignment option is disabled for non-numeric scale bars.

The correct way to lock the reference position of items during resizing is to set the item's reference point - this works correctly for scalebars in 2.x and 3.0.

Also available in: Atom PDF