Bug report #13561

Refine rules dialogs create invalid rules for expressions

Added by Anita Graser almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:21603

Description

This affects Refine current rule | Add categories to rule as well as Add ranges to rule.

If you use an expression such as COL1/COL2 to create a classification, the resulting rule will be, e.g. "COL1/COL2" >= 0 AND "COL1/COL2" <= 10

There are actually two errors here:

  1. QGIS cannot find a column "COL1/COL2" and therefore won't draw the rule.
  2. The rules overlap because they are always generated using >= and <= rather than > and <=.

History

#1 Updated by Nyall Dawson almost 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #10815

Also available in: Atom PDF