Bug report #13558

[Regression] Label/diagram placement on centroid is broken for multipolygons

Added by Anita Graser almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21600

Description

Label/diagram placement on centroid in master seems to be off compared to 2.10: for multipolygons, it seems to randomly chose the centroid of one part rather than the old behavior which seemed to use the whole multipart feature to compute the centroid.

In the following example the diagram is put on the centroid with high priority and the label settings are shown.

Tested on nightly OSGeo4W

210-vs-master.png (211 KB) Anita Graser, 2015-10-10 05:12 AM

label-partial-feature.png (182 KB) Anita Graser, 2015-10-10 06:31 AM

History

#1 Updated by Anita Graser almost 4 years ago

#2 Updated by Nyall Dawson almost 4 years ago

  • Priority changed from High to Severe/Regression

#3 Updated by Anita Graser almost 4 years ago

  • Subject changed from [Regression] Label/diagram placement on centroid is broken for multipolgons to [Regression] Label/diagram placement on centroid is broken for multipolygons

#4 Updated by Anita Graser almost 4 years ago

Update info: If label all parts of multipart feature is enabled ...

When the complete multipolygon is visible in the map view, there are no label candidates on the main land. They appear if the feature is moved partially outside the map view:

#5 Updated by Nyall Dawson almost 4 years ago

Seems to be caused by the recent GEOS c++ changes (tolerance) - if I build without the geos c++ library set then the placement matches 2.10. Can also confirm that https://github.com/qgis/QGIS/pull/2353 fixes this.

#6 Updated by Nyall Dawson almost 4 years ago

  • Status changed from Open to Feedback

Can you please re-test with current master? PR 2353 has been merged, which fixed the issue for me.

#7 Updated by Anita Graser almost 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed
  • Target version changed from Future Release - High Priority to Version 2.12
  • % Done changed from 0 to 100

Looks fine today. Thanks!

Also available in: Atom PDF