Bug report #13557

Capitalize first letter - not working if source is all uppercase

Added by Klas Karlsson almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:21599

Description

Making first letter in each word capital for any label only works if the text is in lower case.

Tested with point layer and three points (attribute: "Name")

To create Capitalized first letters you must use title(Name) in "Label with".

Attached image shows result from four settings for "Type Case" and a fix.
- Normal
- All lowercase
- All uppercase
- Capitalize first letter
- Fix with "expression" title(Name)

result.png (31.3 KB) Klas Karlsson, 2015-10-10 03:16 AM

History

#1 Updated by Nyall Dawson almost 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #7611

Also available in: Atom PDF