Bug report #13554

QGIS 2.10 recently installed crashes when clicked on projection button

Added by Gilberto Magalhaes Leite Filho about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Projection Support
Affected QGIS version:2.10.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:21596

Description

I've just installed version 2.10.1 of QGIS and the program failed when I tried to render a map.
Here are the error messages I received in the terminal:

Warning: loading of qgis translation failed [/usr/share/qgis/i18n//qgis_en_US]
Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_US]

(qgis:19813): Gtk-WARNING **: Theme file for default has no name

(qgis:19813): Gtk-WARNING **: Theme file for default has no directories

Fatal: ASSERT: "myResult == 0" in file /tmp/buildd/qgis-2.10.1+20trusty/src/app/qgsprojectproperties.cpp, line 1514
Stacktrace (piped through c++filt):
qgis[0x4c7bda]
qgis[0x4c7d96]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(qt_message_output(QtMsgType, char const*)+0x21)[0x7f762c999bb1]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(+0x70ff9)[0x7f762c999ff9]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(qFatal(char const*, ...)+0x94)[0x7f762c99a804]
qgis(QgsProjectProperties::populateEllipsoidList()+0x200)[0x700d7e]
qgis(QgsProjectProperties::QgsProjectProperties(QgsMapCanvas*, QWidget*, QFlags<Qt::WindowType>)+0x6f0)[0x6f3560]
qgis(QgisApp::projectProperties()+0x77)[0x50b0e7]
qgis(QgisApp::projectPropertiesProjections()+0x23)[0x50b06d]
qgis[0x88a0e7]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QMetaObject::activate(QObject*, QMetaObject const*, int, void**)+0x2da)[0x7f762caba87a]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QAbstractButton::clicked(bool)+0x32)[0x7f762c48e172]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x57ba63)[0x7f762c1f1a63]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x57cbd3)[0x7f762c1f2bd3]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QAbstractButton::mouseReleaseEvent(QMouseEvent*)+0x6c)[0x7f762c1f2cbc]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QToolButton::mouseReleaseEvent(QMouseEvent*)+0xa)[0x7f762c2a9aca]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QWidget::event(QEvent*)+0xaca)[0x7f762be8f51a]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QApplicationPrivate::notify_helper(QObject*, QEvent*)+0x8c)[0x7f762be3fe2c]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QApplication::notify(QObject*, QEvent*)+0x3ad)[0x7f762be465dd]
/usr/lib/libqgis_core.so.2.10.1(QgsApplication::notify(QObject*, QEvent*)+0x83)[0x7f762e21f4c9]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QCoreApplication::notifyInternal(QObject*, QEvent*)+0x6d)[0x7f762caa64dd]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool)+0x153)[0x7f762be45d93]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x2449eb)[0x7f762beba9eb]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(QApplication::x11ProcessEvent(_XEvent*)+0x1559)[0x7f762beba289]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x26bb32)[0x7f762bee1b32]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x254)[0x7f7627c56e04]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x49048)[0x7f7627c57048]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x2c)[0x7f7627c570ec]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)+0x71)[0x7f762cad37a1]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x26bbe6)[0x7f762bee1be6]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)+0x2f)[0x7f762caa50af]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>)+0x175)[0x7f762caa53a5]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(QCoreApplication::exec()+0x89)[0x7f762caaab79]
qgis[0x4cabb5]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5)[0x7f7629de8ec5]
qgis[0x4c76f9]
Aborted

Details:
Operating System: Linux Mint 17.2 Cinnamon 64-bit
Cinnamon Version: 2.6.13
Kernel version: 3.16.0-38-generic
Processor: Intel Core i5-3470S x 4
Memory: 3.7 GiB
HDD: 476.5GB
Graphics Card: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller

33.png - Screenshot of QGIS version (74.8 KB) Gilberto Magalhaes Leite Filho, 2015-10-09 01:28 PM

20.png - Screenshot of main window (93.2 KB) Gilberto Magalhaes Leite Filho, 2015-10-09 01:28 PM

History

#1 Updated by Nyall Dawson about 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Looks like a duplicate of #13511

Also available in: Atom PDF