Bug report #1350

WMS connection don't work through proxy

Added by Andreas Neumann almost 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11410

Description

With the current trunk, WMS connections don't work through the Proxy. This was confirmed by at least two other persons. See discussion starting at http://lists.osgeo.org/pipermail/qgis-user/2008-October/003514.html

This bug may be related to the following bug:
https://trac.osgeo.org/qgis/ticket/1072

Here is one of the Proxy error messages from Paulo:

----------
Warning: UNEXPECTED RESPONSE: [HTTP/1.0 403 Forbidden
Server: squid/2.6.STABLE12
Date: Tue, 14 Oct 2008 14:47:56 GMT
Content-Type: text/html
Content-Length: 1032
Expires: Tue, 14 Oct 2008 14:47:56 GMT
X-Squid-Error: ERR_ACCESS_DENIED 0
X-Cache: MISS from proxy.arpa.piemonte.it
Via: 1.0 proxy.arpa.piemonte.it:3128 (squid/2.6.STABLE12)
Proxy-Connection: close
------------

Here is the proxy error message from Carson:

------------
Warning: UNEXPECTED RESPONSE: [HTTP/1.0 403 Forbidden
server: squid/2.5.STABLE14
mime-version: 1.0
date: Tue, 14 Oct 2008 15:35:22 GMT
content-type: text/html
content-length: 1045
expires: Tue, 14 Oct 2008 15:35:22 GMT
x-squid-error: ERR_ACCESS_DENIED 0
x-cache: MISS from whitethorn.nuim.ie
proxy-connection: close
-----------------

Thank you for having a look at this bug.

History

#1 Updated by Paolo Cavallini almost 12 years ago

I think this is reated to a bug in Qt, as also other Qt apps on the same system do not work through the same proxy. It is not limited to WMS: any request that should be proxyed (eg going to QGIS web page) does not work.
This is not debian-specific, as it shows up also on Fedora core 9.

#2 Updated by monty - almost 12 years ago

Qgis use the HTTP CONNECT method to connect to the wms server. Disable the Connect Restriction in your squid.conf:

  1. Deny CONNECT to other than SSL ports
  • http_access deny CONNECT SSL_ports

#3 Updated by Andreas Neumann almost 12 years ago

thanks for the hint - unfortunately I don't have access to the proxy configuration - this is a state-wide setting out of my control. However, I can ask the administrators of the proxy to look into the issue. I will report back if you suggestion solves my issue. It looks like this restriction in the proxy setting could be the cause.

Thanks for your help,
Andreas

#4 Updated by marchesinivan - over 11 years ago

I'm using debian testing
I have just installed qgis 1.0.1

We have a proxy of this type: 192.168.10.13 - port: 80

I have tried to use settings -> optins -> Proxy to define the proxy server but the answer, when I try to connect to a wms server is:
"Could not understand the response. The wms provider said:"

the console says:

++++++++++++
Warning: UNEXPECTED RESPONSE: [HTTP/1.1 502 Proxy Error ( The specified Secure Sockets Layer (SSL) port is not allowed. ISA Server is not configured to allow SSL requests from this port. Most Web browsers use port 443 for SSL requests. )
Via: 1.1 ISAREGUMB
Connection: close
Proxy-Connection: close
Pragma: no-cache
Cache-Control: no-cache
Content-Type: text/html
Content-Length: 781

]
Warning: UNEXPECTED RESPONSE: [HTTP/1.1 502 Proxy Error ( The specified Secure Sockets Layer (SSL) port is not allowed. ISA Server is not configured to allow SSL requests from this port. Most Web browsers use port 443 for SSL requests. )
Via: 1.1 ISAREGUMB
Connection: close
Proxy-Connection: close
Pragma: no-cache
Cache-Control: no-cache
Content-Type: text/html
Content-Length: 781

]
++++++++_

It seems a problem of SSL??

That's all...
I think this problem is a major problem and can create difficulties to the introduction of Qgis into the Public Administrations

Thanks to all

Ivan

#5 Updated by Jürgen Fischer over 11 years ago

Replying to [comment:4 marchesinivan]:

Warning: UNEXPECTED RESPONSE: [HTTP/1.1 502 Proxy Error ( The specified Secure Sockets Layer (SSL) port is not allowed. ISA Server is not configured to allow SSL requests from this port. Most Web browsers use port 443 for SSL requests. )

[...]

It seems a problem of SSL??

No, as monty pointed out QGIS uses HTTP CONNECT to access the WMS server thought the proxy. But the proxy you use is configured to restrict HTTP CONNECT to port 443 (usually used HTTPS).

Perhaps it helps when you switch from HttpProxy to HttpCachingProxy (but I think that's currently available in 1.1 only).

#6 Updated by Jürgen Fischer over 11 years ago

Replying to [comment:5 jef]:

Perhaps it helps when you switch from HttpProxy to HttpCachingProxy (but I think that's currently available in 1.1 only).

Yes, that helps. Leaving this ticket open - as we should probably backport this to 1.0.

#7 Updated by marchesinivan - over 11 years ago

Replying to [comment:6 jef]:

Replying to [comment:5 jef]:

Perhaps it helps when you switch from HttpProxy to HttpCachingProxy (but I think that's currently available in 1.1 only).

Yes, that helps. Leaving this ticket open - as we should probably backport this to 1.0.

I have just installed osgeo qgis trunk and setting HttpProxy I can use WMS!!!

good!!! as soon as possible I will test it on debian

#8 Updated by Andreas Neumann over 11 years ago

I think this bug should be closed now. It works fine for me.

Andreas

#9 Updated by Paolo Cavallini over 11 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

#10 Updated by Anonymous about 11 years ago

Milestone Version 1.0.2 deleted

Also available in: Atom PDF